So, the issue was that in https://github.com/nextcloud/collectives/pull/2289 (Included in release 4.0) the collectives app changed the default save location from /Collectives to /.Collectives to hide the folder in the file view. This also moves all files to the new location. In the default serverside encryption module encryption information is stored in the db with the path as the identifier. So all files that were moved (including the templates) were unable to be decrypted.
The fix is
Changing the default back to /Collectives with nextcloud-occ config:app:set --value="/Collectives" collectives default_user_folder
changing the location back using nextcloud-occ user:setting {user} collectives user_folder /Collectives for each user
So, the issue was that in https://github.com/nextcloud/collectives/pull/2289 (Included in release 4.0) the collectives app changed the default save location from /Collectives to /.Collectives to hide the folder in the file view. This also moves all files to the new location. In the default serverside encryption module encryption information is stored in the db with the path as the identifier. So all files that were moved (including the templates) were unable to be decrypted.
The fix is
1. Changing the default back to /Collectives with `nextcloud-occ config:app:set --value="/Collectives" collectives default_user_folder`
2. changing the location back using `nextcloud-occ user:setting {user} collectives user_folder /Collectives` for each user
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
I'm pretty sure this happened once already... How did we fix it? Just recreate them?
Why did this happen? Update?
Document fix
So, the issue was that in https://github.com/nextcloud/collectives/pull/2289 (Included in release 4.0) the collectives app changed the default save location from /Collectives to /.Collectives to hide the folder in the file view. This also moves all files to the new location. In the default serverside encryption module encryption information is stored in the db with the path as the identifier. So all files that were moved (including the templates) were unable to be decrypted.
The fix is
nextcloud-occ config:app:set --value="/Collectives" collectives default_user_foldernextcloud-occ user:setting {user} collectives user_folder /Collectivesfor each user